2018+ Ford EcoSport banner
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi all. Have had my Ecosport from new for two and a half years and only 12000ish miles. All has been good until tonight when the screen froze on one radio station..... No response to any controls on either touchscreen of manual buttons on the fascia.... Steering wheel controls only work for volume up/down.
It reset and worked OK for the first 2miles of the return journey then failed again..... Then at the end of the journey I got out and locked the car but the screen stayed on.

Anyone else had this?

Is there a fix?
 

·
Registered
Joined
·
20 Posts
Hi all. Have had my Ecosport from new for two and a half years and only 12000ish miles. All has been good until tonight when the screen froze on one radio station..... No response to any controls on either touchscreen of manual buttons on the fascia.... Steering wheel controls only work for volume up/down.
It reset and worked OK for the first 2miles of the return journey then failed again..... Then at the end of the journey I got out and locked the car but the screen stayed on.

Anyone else had this?

Is there a fix?
I'm currently dealing with this! The screen is suspected as the problem. May be waiting months for a display replacement.
 

·
Registered
Joined
·
10 Posts
Hi all. Have had my Ecosport from new for two and a half years and only 12000ish miles. All has been good until tonight when the screen froze on one radio station..... No response to any controls on either touchscreen of manual buttons on the fascia.... Steering wheel controls only work for volume up/down.
It reset and worked OK for the first 2miles of the return journey then failed again..... Then at the end of the journey I got out and locked the car but the screen stayed on.

Anyone else had this?

Is there a fix?
I never had any issues with my 2021 EcoSport Radio until i got the last update at the Ford Dealership. I've had mine completely lock but still playing music or a station on FM, though every control was locked. When i got home I shut off the vehicle, opened the door, shut it, restarted and everything worked ok. I can't tell you what version software i have now, i think 3.4 something, but if it keeps happening I'll bring it in for service. I only have 6000 miles on mine.
 
1 - 4 of 4 Posts
Top