Remote starter and heater options 2018 Titanium - 2018+ Ford EcoSport Forum
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 12-30-2018, 11:44 AM Thread Starter
Junior Member
 
Join Date: Dec 2018
Posts: 3
Remote starter and heater options 2018 Titanium

I'm having problems getting the warming features on our 2018 Titanium Ecosport (heater, steering wheel and seat heat) to activate when the remote starter is used. I've gone through the owner manual and setup several times and choosing auto or current settings doesn't turn it on? Prefer to resolve this before having to take it back to the dealership . Would like to get into a warm vehicle on these Yukon winter days.
44sourdough is offline  
post #2 of 7 (permalink) Old 12-30-2018, 01:29 PM
Member
 
Join Date: Jan 2018
Posts: 64
Best guess is there are still some extra settings hidden somewhere in the cluster menu. If you've already set everything to automatic and its still not heating properly there may be a software issue. I know sometimes these things are restricted by certain temperatures.
Orion is offline  
post #3 of 7 (permalink) Old 12-31-2018, 09:28 AM Thread Starter
Junior Member
 
Join Date: Dec 2018
Posts: 3
Thanks for the information. I'll see if there is any software updates I can install myself otherwise....back to the dealership.
44sourdough is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 01-08-2019, 10:17 AM
Junior Member
 
Join Date: Jan 2018
Posts: 28
Curious to hear what the fix is if you have to make a trip to the dealer. I think you may have to manually turn on your heated seats/steering wheel when turning off your vehicle the previous day.
Zeke is offline  
post #5 of 7 (permalink) Old 01-10-2019, 04:05 PM
Senior Member
 
Join Date: Nov 2016
Posts: 260
Sometimes automakers leave weird tasks up to technicians to perform during the pre-delivery inspection (PDI), this might be one of them.
So as you can guess what i'll recommend, dealer is your first stop
workingclasshero is offline  
post #6 of 7 (permalink) Old 01-13-2019, 09:45 AM Thread Starter
Junior Member
 
Join Date: Dec 2018
Posts: 3
I haven't made it to the dealer since our weather has been hovering around -40 for the past week keeping the Ecosport in the garage not wanting to test its reliability at these temperatures.... just yet. Did however disconnect the battery for a few hours. Connected the battery and tried the remote start ,though there is no display, there is heat blowing, seat and steering wheel warms as it should? Maybe just a fluke that it rebooted the system? Think I'll wait on the dealership for now.
44sourdough is offline  
post #7 of 7 (permalink) Old 01-20-2019, 11:52 PM
Senior Member
 
Join Date: Nov 2016
Posts: 260
I heard that in some cases pulling the main fuse does the trick but being such a new vehicle I wouldn't go that far, instead, give it to the dealer.
workingclasshero is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome