Intermittent Hill Start Assist not available error - 2018+ Ford EcoSport Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 04-09-2019, 12:35 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 2
Intermittent Hill Start Assist not available error

Hi all. As the title says we're getting an intermittent "Hill start assist not available" error. This has happened on and off since we purchased our brand new Ecosport ST Line in November last year.

Initially it happened just once in early December. Then it happened a few more times in January, so we booked it in with our local Ford garage. Unfortunately they insisted that the problem was caused by the rubber car mats we were using. This wasn't the case at all. We'd been toying with getting fitted rubber mats anyway and decided seeing as they thought ours were an issue that we'd buy the official Ford Ecosport ones. Got a very good deal via another Ford garage in eBay. Surprise, surprise within a week the error came back.

We then decided to try another Ford garage, slightly less local, but from a smaller group, as we felt a little fobbed off with the first place. They suggested we see if the error came on more permanently and then book it in. After a few weeks this didn't happen, but after another chat we decided to take it in for them to check anyway. They found an error code for a reverse switch that needed replacing and fixed it. They thought that maybe that was the culprit.

The very next day after weeks of the error not happening it came on again! This last garage are no longer a Ford seller and so cannot give us a like for like courtesy car while they keep it for at least a week to see if they can find the problem. So, our current thoughts are to wait and see if it comes on more permanently like was originally suggested.

Anyone else come across anything similar? Googling finds various other Fords with similar issues historically, but no concrete fixes.
Prawnyloks is offline  
post #2 of 3 (permalink) Old 04-09-2019, 12:39 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 2
Here’s a pic of the dash error. It's also logged on my FordPass app.
Attached Images
File Type: jpg 976091B9-3903-499E-9546-8B825D600733_1554827935292.jpg (56.6 KB, 7 views)
Prawnyloks is offline  
post #3 of 3 (permalink) Old 04-14-2019, 11:59 PM
Senior Member
 
Join Date: Nov 2016
Posts: 260
I suggest you get a second opinion from another dealership.

From my experience, I realized that service from dealer to dealer can vary quite a lot. Some so bad I have seen some folks only go to independent shops that specialize in their make/model.
workingclasshero is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome